#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)a"
Local $sString = "Quisque et pharetra sapien. Aenean nunc leo, volutpat vel odio id, facilisis scelerisque lorem. Vivamus mollis vitae diam quis consequat. Vestibulum ut pulvinar risus. Nulla blandit nec velit at efficitur. Fusce convallis vehicula tellus et tempus. Aenean ac mattis felis, ac volutpat odio. Aenean faucibus tellus eget sodales gravida. Nulla nec malesuada sapien. Nullam sollicitudin lacus a sem congue, quis molestie dui mollis. Phasellus ornare iaculis diam sit amet posuere."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")