const regex = new RegExp('a', 'gm')
const str = `Quisque et pharetra sapien. Aenean nunc leo, volutpat vel odio id, facilisis scelerisque lorem. Vivamus mollis vitae diam quis consequat. Vestibulum ut pulvinar risus. Nulla blandit nec velit at efficitur. Fusce convallis vehicula tellus et tempus. Aenean ac mattis felis, ac volutpat odio. Aenean faucibus tellus eget sodales gravida. Nulla nec malesuada sapien. Nullam sollicitudin lacus a sem congue, quis molestie dui mollis. Phasellus ornare iaculis diam sit amet posuere.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}