// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)a").unwrap();
let string = "Quisque et pharetra sapien. Aenean nunc leo, volutpat vel odio id, facilisis scelerisque lorem. Vivamus mollis vitae diam quis consequat. Vestibulum ut pulvinar risus. Nulla blandit nec velit at efficitur. Fusce convallis vehicula tellus et tempus. Aenean ac mattis felis, ac volutpat odio. Aenean faucibus tellus eget sodales gravida. Nulla nec malesuada sapien. Nullam sollicitudin lacus a sem congue, quis molestie dui mollis. Phasellus ornare iaculis diam sit amet posuere.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}