import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(?=(?'a'[\\s\\S]*))(?'b'eat_(?:apple|pear|orange)_(?=\\k'a'\\z)|(?<=(?=x^|(?&b))[\\s\\S])))today|yesterday";
final String string = "eat_pear_today\n"
+ "yesterday";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}