re = /(?=(?=(?'a'[\s\S]*))(?'b'eat_(?:apple|pear|orange)_(?=\k'a'\z)|(?<=(?=x^|(?&b))[\s\S])))today|yesterday/m
str = 'eat_pear_today
yesterday'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end