using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((09|10|11|12|13|14|15|16|17|18|19|20|21):([0-5]\d))|(22:00)";
string input = @"00:35
08:59
09:22
11:55
22:00
23:00";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}