$re = '/((09|10|11|12|13|14|15|16|17|18|19|20|21):([0-5]\d))|(22:00)/';
$str = '00:35
08:59
09:22
11:55
22:00
23:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);