import Foundation
let pattern = #"((09|10|11|12|13|14|15|16|17|18|19|20|21):([0-5]\d))|(22:00)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
00:35
08:59
09:22
11:55
22:00
23:00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)