#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*one)(?=.*two)(?=.*three)(?=[^A-Z]*[A-Z][^A-Z]*[A-Z])(?=[^a-z]*[a-z][^a-z]*[a-z])(?=\D*\d\D*\d)(?=[A-Za-z0-9]*[^A-Za-z0-9][A-Za-z0-9]*[^A-Za-z0-9]).*$"
Local $sString = "onetwothreeABab12@#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")