re = /(?=.*one)(?=.*two)(?=.*three)(?=[^A-Z]*[A-Z][^A-Z]*[A-Z])(?=[^a-z]*[a-z][^a-z]*[a-z])(?=\D*\d\D*\d)(?=[A-Za-z0-9]*[^A-Za-z0-9][A-Za-z0-9]*[^A-Za-z0-9]).*$/m
str = 'onetwothreeABab12@#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end