$re = '/(?=.*one)(?=.*two)(?=.*three)(?=[^A-Z]*[A-Z][^A-Z]*[A-Z])(?=[^a-z]*[a-z][^a-z]*[a-z])(?=\D*\d\D*\d)(?=[A-Za-z0-9]*[^A-Za-z0-9][A-Za-z0-9]*[^A-Za-z0-9]).*$/m';
$str = 'onetwothreeABab12@#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);