using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.\d{1,3}\B(?!\d)";
string substitution = @"$0 ";
string input = @"1.9 Beef Curry
1.10Banana Pie
1.11 Corn Gravy
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}