use strict;
my $str = '1.9 Beef Curry
1.10Banana Pie
1.11 Corn Gravy
';
my $regex = qr/\.\d{1,3}\B(?!\d)/mp;
my $subst = '$0 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";