re = /\.\d{1,3}\B(?!\d)/m
str = '1.9 Beef Curry
1.10Banana Pie
1.11 Corn Gravy
'
subst = '$0 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result