using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<root>[A-G][#b]?)(?<suffix>[^\/]*)(?:\/(?<bass>[A-G][#b]?))?";
string input = @"Abadd9/C#";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}