$re = '/(?<root>[A-G][#b]?)(?<suffix>[^\/]*)(?:\/(?<bass>[A-G][#b]?))?/m';
$str = 'Abadd9/C#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);