re = /(?<root>[A-G][#b]?)(?<suffix>[^\/]*)(?:\/(?<bass>[A-G][#b]?))?/m
str = 'Abadd9/C#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end