re = /\#\#\ (\d(\.\d)?(\.\d)?)/m
str = '# Changelog
## 1.2.3'
subst = '## [$1](StorybookURL/$1)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result