# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{1})[-](\d{3})[-](\d{3})[-](\d{4})//gm;t' <<< "2124567890
212-456-7890
(212)456-7890
(212)-456-7890
212.456.7890
212 456 7890
+12124567890
+12124567890
+1 212.456.7890
+212-456-7890
1-212-456-7890
1-21-345-7890
"