import re
regex = re.compile(r"(\d{1})[-](\d{3})[-](\d{3})[-](\d{4})", flags=re.MULTILINE)
test_str = ("2124567890\n"
"212-456-7890\n"
"(212)456-7890\n"
"(212)-456-7890\n"
"212.456.7890\n"
"212 456 7890\n"
"+12124567890\n"
"+12124567890\n"
"+1 212.456.7890\n"
"+212-456-7890\n"
"1-212-456-7890\n"
"1-21-345-7890\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)