const regex = new RegExp('^([*]\\s(?!\\d|--).+)((?:\\n(?!--).*)*)', 'gm')
const str = `* 02.04.2021 09:23:25 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
NonConformity 0001 :
Type of nonconformity : Scratch
* NonConformity 0002 :
Type of nonconformity : Scratch - cosmetical item
* Il a été constaté des rayures sur L'ENS CASQUETTE réf :
D54.
* Voir standard doc.
* Nous demandons le renvoi de la pièce pour une remise en
conformité.
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
02.04.2021 09:31:27 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
Task Completed : 0100 \`\` DEC0 \`\`
Decision Taken : REJECT
Justification :
* 02.04.2021 09:23:25 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
NonConformity 0001 :
Type of nonconformity : Scratch
* 4 NonConformity 0002 :
Type of nonconformity : Scratch - cosmetical item
* Il a été constaté des rayures sur L'ENS CASQUETTE réf :
D54.
* Voir standard doc.
* Nous demandons le renvoi de la pièce pour une remise en
conformité.
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
02.04.2021 09:31:27 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
Task Completed : 0100 \`\` DEC0 \`\`
Decision Taken : REJECT
Justification :`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}