import re
regex = re.compile(r"^([*]\s(?!\d|--).+)((?:\n(?!--).*)*)", flags=re.MULTILINE)
test_str = ("* 02.04.2021 09:23:25 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~\n"
"NonConformity 0001 :\n"
"Type of nonconformity : Scratch\n"
"* NonConformity 0002 :\n"
"Type of nonconformity : Scratch - cosmetical item\n"
"* Il a été constaté des rayures sur L'ENS CASQUETTE réf :\n"
"D54.\n"
"* Voir standard doc.\n"
"* Nous demandons le renvoi de la pièce pour une remise en\n"
"conformité.\n"
"-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --\n"
"-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --\n"
"02.04.2021 09:31:27 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~\n"
"Task Completed : 0100 `` DEC0 ``\n"
"Decision Taken : REJECT\n"
"Justification :\n\n"
"* 02.04.2021 09:23:25 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~\n"
"NonConformity 0001 :\n"
"Type of nonconformity : Scratch\n"
"* 4 NonConformity 0002 :\n"
"Type of nonconformity : Scratch - cosmetical item\n"
"* Il a été constaté des rayures sur L'ENS CASQUETTE réf :\n"
"D54.\n"
"* Voir standard doc.\n"
"* Nous demandons le renvoi de la pièce pour une remise en\n"
"conformité.\n"
"-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --\n"
"-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --\n"
"02.04.2021 09:31:27 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~\n"
"Task Completed : 0100 `` DEC0 ``\n"
"Decision Taken : REJECT\n"
"Justification :")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")