re = /^([*]\s(?!\d|--).+)((?:\n(?!--).*)*)/m
str = '* 02.04.2021 09:23:25 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
NonConformity 0001 :
Type of nonconformity : Scratch
* NonConformity 0002 :
Type of nonconformity : Scratch - cosmetical item
* Il a été constaté des rayures sur L\'ENS CASQUETTE réf :
D54.
* Voir standard doc.
* Nous demandons le renvoi de la pièce pour une remise en
conformité.
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
02.04.2021 09:31:27 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
Task Completed : 0100 `` DEC0 ``
Decision Taken : REJECT
Justification :
* 02.04.2021 09:23:25 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
NonConformity 0001 :
Type of nonconformity : Scratch
* 4 NonConformity 0002 :
Type of nonconformity : Scratch - cosmetical item
* Il a été constaté des rayures sur L\'ENS CASQUETTE réf :
D54.
* Voir standard doc.
* Nous demandons le renvoi de la pièce pour une remise en
conformité.
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
02.04.2021 09:31:27 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
Task Completed : 0100 `` DEC0 ``
Decision Taken : REJECT
Justification :'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end