package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?im)(.+)\s*\+\s*(.+)`)
var str = `A+B+C+D`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}