import re
regex = re.compile(r"(?im)(.+)\s*\+\s*(.+)", flags=re.MULTILINE)
test_str = "A+B+C+D"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)