$re = '/(?im)(.+)\s*\+\s*(.+)/m';
$str = 'A+B+C+D';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;