import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(array\\()([a-z=>'_ ]*)(\\))(.*)";
final String string = ">columns(array('f_motivo' => new Expression(\"m.no_motivo\"), 'f_descricao' => new Expression(\"('Data: ' || to_char(fi.dt_inativacao, 'DD/MM/YYYY') || '. Descrição: ' || (case when fi.ds_motivo is null then ' - ' else fi.ds_motivo end))\"), array('dt_order' => 'dt_inativacao')))";
final String subst = "$1[$3]$5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}