re = /(.*)(array\()([a-z=>'_ ]*)(\))(.*)/
str = '>columns(array(\'f_motivo\' => new Expression("m.no_motivo"), \'f_descricao\' => new Expression("(\'Data: \' || to_char(fi.dt_inativacao, \'DD/MM/YYYY\') || \'. Descrição: \' || (case when fi.ds_motivo is null then \' - \' else fi.ds_motivo end))"), array(\'dt_order\' => \'dt_inativacao\')))'
subst = '$1[$3]$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result