// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)(array\()([a-z=>'_ ]*)(\))(.*)").unwrap();
let string = ">columns(array('f_motivo' => new Expression(\"m.no_motivo\"), 'f_descricao' => new Expression(\"('Data: ' || to_char(fi.dt_inativacao, 'DD/MM/YYYY') || '. Descrição: ' || (case when fi.ds_motivo is null then ' - ' else fi.ds_motivo end))\"), array('dt_order' => 'dt_inativacao')))";
let substitution = "$1[$3]$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}