import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([a-z]+)?([0-9]+))";
final String string = "[\"AA\",\"BB\",\"CC\",\"DD\",\"EE\",\"FF\",\"GG\",\"AAA\",\"SSS\",\"sDDD\",\"mFFFa\"],\"gaa\":\"aaa\",\"timasa});\n"
+ "**var csrf_token = '551a8513';**";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}