import re
regex = re.compile(r"(([a-z]+)?([0-9]+))", flags=re.MULTILINE)
test_str = ("[\"AA\",\"BB\",\"CC\",\"DD\",\"EE\",\"FF\",\"GG\",\"AAA\",\"SSS\",\"sDDD\",\"mFFFa\"],\"gaa\":\"aaa\",\"timasa});\n"
"**var csrf_token = '551a8513';**")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")