using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<=""customfield_11301"":).*?(?=""customfield_10730"")";
string input = @" ""customfield_11300"": null,
""customfield_11301"": [
{
""self"": ""xxxxxxxx"",
""value"": ""xxxxxxxxx"",
""id"": ""10467""
}
],
""customfield_10730"": null,
""customfield_11302"": null,
""customfield_10720"": 0.0,
""customfield_11300"": null,
""customfield_11301"": [
{
""self"": ""zzzzzzzzzzzzz"",
""value"": ""zzzzzzzzzzz"",
""id"": ""10467""
}
],
""customfield_10730"": null,
""customfield_11302"": null,
""customfield_10720"": 0.0,";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}