import re
regex = re.compile(r"(?s)(?<=\"\"customfield_11301\"\":).*?(?=\"\"customfield_10730\"\")", flags=re.IGNORECASE)
test_str = (" \"customfield_11300\": null,\n"
" \"customfield_11301\": [\n"
" {\n"
" \"self\": \"xxxxxxxx\",\n"
" \"value\": \"xxxxxxxxx\",\n"
" \"id\": \"10467\"\n"
" }\n"
" ],\n"
" \"customfield_10730\": null,\n"
" \"customfield_11302\": null,\n"
" \"customfield_10720\": 0.0,\n"
" \"customfield_11300\": null,\n"
" \"customfield_11301\": [\n"
" {\n"
" \"self\": \"zzzzzzzzzzzzz\",\n"
" \"value\": \"zzzzzzzzzzz\",\n"
" \"id\": \"10467\"\n"
" }\n"
" ],\n"
" \"customfield_10730\": null,\n"
" \"customfield_11302\": null,\n"
" \"customfield_10720\": 0.0,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")