import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?<=\"\"customfield_11301\"\":).*?(?=\"\"customfield_10730\"\")";
final String string = " \"customfield_11300\": null,\n"
+ " \"customfield_11301\": [\n"
+ " {\n"
+ " \"self\": \"xxxxxxxx\",\n"
+ " \"value\": \"xxxxxxxxx\",\n"
+ " \"id\": \"10467\"\n"
+ " }\n"
+ " ],\n"
+ " \"customfield_10730\": null,\n"
+ " \"customfield_11302\": null,\n"
+ " \"customfield_10720\": 0.0,\n"
+ " \"customfield_11300\": null,\n"
+ " \"customfield_11301\": [\n"
+ " {\n"
+ " \"self\": \"zzzzzzzzzzzzz\",\n"
+ " \"value\": \"zzzzzzzzzzz\",\n"
+ " \"id\": \"10467\"\n"
+ " }\n"
+ " ],\n"
+ " \"customfield_10730\": null,\n"
+ " \"customfield_11302\": null,\n"
+ " \"customfield_10720\": 0.0,";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}