const regex = /([a-zA-Z]+) \/(De|La|Le|Van|Von) /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]+) \\\/(De|La|Le|Van|Von) ', 'gm')
const str = `0 @I@ INDI 1 NAME Anna /Von Hat/ 2 GIVN Anna 2 SURN Von Hat 1 BIRT 2 DATE 01 Jan 2000 2 PLAC Copenhagen, Copenhagen, Denmark`;
const subst = `$1 $2 /`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);