import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(a\\shref)=\"\\w{4,5}:\\/\\/\\w+.\\w{2}\">\\w+(<\\/a>)";
final String string = "<ul> <li> <a href=\"http://softuni.bg\">SoftUni</a></li></ul>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}