re = /<(a\shref)="\w{4,5}:\/\/\w+.\w{2}">\w+(<\/a>)/
str = '<ul> <li> <a href="http://softuni.bg">SoftUni</a></li></ul>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end