#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((19|20)\d\d[- \/.](0[1-9]|1[012])[- \/.](0[1-9]|[12][0-9]|3[01]))|((0[1-9]|1[012])[- \/.](0[1-9]|[12][0-9]|3[01])[- \/.](19|20)\d\d)|((0[1-9]|[12][0-9]|3[01])[- \/.](0[1-9]|1[012])[- \/.](19|20)\d\d))$"
Local $sString = "2020/02/19" & @CRLF & _
"19/02/2020" & @CRLF & _
"02/19/2020" & @CRLF & _
"" & @CRLF & _
"2020 02 19" & @CRLF & _
"19 02 2020" & @CRLF & _
"02 19 2020" & @CRLF & _
"" & @CRLF & _
"2020-02-19" & @CRLF & _
"19-02-2020" & @CRLF & _
"02-19-2020" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")