package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((19|20)\d\d[- \/.](0[1-9]|1[012])[- \/.](0[1-9]|[12][0-9]|3[01]))|((0[1-9]|1[012])[- \/.](0[1-9]|[12][0-9]|3[01])[- \/.](19|20)\d\d)|((0[1-9]|[12][0-9]|3[01])[- \/.](0[1-9]|1[012])[- \/.](19|20)\d\d))$`)
var str = `2020/02/19
19/02/2020
02/19/2020
2020 02 19
19 02 2020
02 19 2020
2020-02-19
19-02-2020
02-19-2020
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}