re = /^(((19|20)\d\d[- \/.](0[1-9]|1[012])[- \/.](0[1-9]|[12][0-9]|3[01]))|((0[1-9]|1[012])[- \/.](0[1-9]|[12][0-9]|3[01])[- \/.](19|20)\d\d)|((0[1-9]|[12][0-9]|3[01])[- \/.](0[1-9]|1[012])[- \/.](19|20)\d\d))$/m
str = '2020/02/19
19/02/2020
02/19/2020
2020 02 19
19 02 2020
02 19 2020
2020-02-19
19-02-2020
02-19-2020
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end