#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}"
Local $sString = "IP=FE80:0000:0000:0000:0202:B3FF:FE1E:8329 message='Hey&son' user=mother" & @CRLF & _
"IP=192.23.33.40 message='Hi&mom!' user=child0" & @CRLF & _
"IP=192.23.30.40 message='Hi&from&me&too' user=child1" & @CRLF & _
"IP=192.23.30.42 message='spam' user=destroyer" & @CRLF & _
"IP=192.23.30.42 message='spam' user=destroyer" & @CRLF & _
"IP=192.23.50.40 message='' user=yetAnotherUsername" & @CRLF & _
"IP=192.23.50.40 message='comment' user=yetAnotherUsername" & @CRLF & _
"IP=192.23.155.40 message='Hello.' user=unknown" & @CRLF & _
"end" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")