use strict;
my $str = 'IP=FE80:0000:0000:0000:0202:B3FF:FE1E:8329 message=\'Hey&son\' user=mother
IP=192.23.33.40 message=\'Hi&mom!\' user=child0
IP=192.23.30.40 message=\'Hi&from&me&too\' user=child1
IP=192.23.30.42 message=\'spam\' user=destroyer
IP=192.23.30.42 message=\'spam\' user=destroyer
IP=192.23.50.40 message=\'\' user=yetAnotherUsername
IP=192.23.50.40 message=\'comment\' user=yetAnotherUsername
IP=192.23.155.40 message=\'Hello.\' user=unknown
end
';
my $regex = qr/(?:[0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}