# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}"
test_str = ("IP=FE80:0000:0000:0000:0202:B3FF:FE1E:8329 message='Hey&son' user=mother\n"
"IP=192.23.33.40 message='Hi&mom!' user=child0\n"
"IP=192.23.30.40 message='Hi&from&me&too' user=child1\n"
"IP=192.23.30.42 message='spam' user=destroyer\n"
"IP=192.23.30.42 message='spam' user=destroyer\n"
"IP=192.23.50.40 message='' user=yetAnotherUsername\n"
"IP=192.23.50.40 message='comment' user=yetAnotherUsername\n"
"IP=192.23.155.40 message='Hello.' user=unknown\n"
"end\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.