import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{@if\\[([A-Za-z0-9]*)(==|===|!=|!==|<|>|<=|>=|true|false)([A-Za-z0-9]*)](.*?)\\}\\}[\\r\\n]{0,}(.*?)[\\r\\n]{0,}\\{\\{end \\4\\}\\}";
final String string = "{{@if[true]ifID1}}\n"
+ " {{@if[1==1]ifID2}}\n"
+ " Hello, World\n"
+ " {{end ifID2}}\n"
+ "{{end ifID1}}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}