const regex = /{{@if\[([A-Za-z0-9]*)(==|===|!=|!==|<|>|<=|>=|true|false)([A-Za-z0-9]*)](.*?)}}[\r\n]{0,}(.*?)[\r\n]{0,}{{end \4}}/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{@if\\[([A-Za-z0-9]*)(==|===|!=|!==|<|>|<=|>=|true|false)([A-Za-z0-9]*)](.*?)}}[\\r\\n]{0,}(.*?)[\\r\\n]{0,}{{end \\4}}', 's')
const str = `{{@if[true]ifID1}}
{{@if[1==1]ifID2}}
Hello, World
{{end ifID2}}
{{end ifID1}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}