use strict;
my $str = '{{@if[true]ifID1}}
{{@if[1==1]ifID2}}
Hello, World
{{end ifID2}}
{{end ifID1}}';
my $regex = qr/{{@if\[([A-Za-z0-9]*)(==|===|!=|!==|<|>|<=|>=|true|false)([A-Za-z0-9]*)](.*?)}}[\r\n]{0,}(.*?)[\r\n]{0,}{{end \4}}/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}