import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=ต\\s)|(?<=ต\\.)|(?<=แขวง)|(?<=ตำบล.\\s))([ก-๙]+)";
final String string = "นาง ทองจันทร์ พิลึก ที่อยู่ 119/3 หมู่ 17 ต.ปากช่อง อ.ปากช่อง จ.นครราชสีมา 23120 เบอร์ติดต่อ 0982266109\n"
+ "นาง ทองจันทร์ พิลึก ที่อยู่ 119/3 หมู่ 17 ต ปากช่อง อ.ปากช่อง จ.นครราชสีมา 23120 เบอร์ติดต่อ 0982266109\n"
+ "จิตรา หงษ์ภูมี บริษัทสากลบอตตลิ่งจำกัด 70ถ.งามวงศ์วาน แขวง/ตำบล: บางกระสอ เขต/อำเภอ: เมือง จังหวัด: นนทบุรี รหัสไปรษณีย์: 11000 เบอร์โทร: 0809309851\n"
+ "นส.วราพร แซ่เติ๋น 129/1 ซ.อ่อนนุช 35 แขวงสวนหลวง เขตสวนหลวง กรุงเทพมหานคร 10250 0654201801\n"
+ "เนตยา ถิ่นทอง 222/234 หมู่บ้่านเออร์เบิน-สาทร ถ.ราชพฤกษ์ แขวงบางจาก ขตภาษีเจริญ กทม.. 10160 0815659384";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}