const regex = new RegExp('((?<=ต\\s)|(?<=ต\\.)|(?<=แขวง)|(?<=ตำบล.\\s))([ก-๙]+)', 'gm')
const str = `นาง ทองจันทร์ พิลึก ที่อยู่ 119/3 หมู่ 17 ต.ปากช่อง อ.ปากช่อง จ.นครราชสีมา 23120 เบอร์ติดต่อ 0982266109
นาง ทองจันทร์ พิลึก ที่อยู่ 119/3 หมู่ 17 ต ปากช่อง อ.ปากช่อง จ.นครราชสีมา 23120 เบอร์ติดต่อ 0982266109
จิตรา หงษ์ภูมี บริษัทสากลบอตตลิ่งจำกัด 70ถ.งามวงศ์วาน แขวง/ตำบล: บางกระสอ เขต/อำเภอ: เมือง จังหวัด: นนทบุรี รหัสไปรษณีย์: 11000 เบอร์โทร: 0809309851
นส.วราพร แซ่เติ๋น 129/1 ซ.อ่อนนุช 35 แขวงสวนหลวง เขตสวนหลวง กรุงเทพมหานคร 10250 0654201801
เนตยา ถิ่นทอง 222/234 หมู่บ้่านเออร์เบิน-สาทร ถ.ราชพฤกษ์ แขวงบางจาก ขตภาษีเจริญ กทม.. 10160 0815659384`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}