# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<=ต\s)|(?<=ต\.)|(?<=แขวง)|(?<=ตำบล.\s))([ก-๙]+)"
test_str = ("นาง ทองจันทร์ พิลึก ที่อยู่ 119/3 หมู่ 17 ต.ปากช่อง อ.ปากช่อง จ.นครราชสีมา 23120 เบอร์ติดต่อ 0982266109\n"
"นาง ทองจันทร์ พิลึก ที่อยู่ 119/3 หมู่ 17 ต ปากช่อง อ.ปากช่อง จ.นครราชสีมา 23120 เบอร์ติดต่อ 0982266109\n"
"จิตรา หงษ์ภูมี บริษัทสากลบอตตลิ่งจำกัด 70ถ.งามวงศ์วาน แขวง/ตำบล: บางกระสอ เขต/อำเภอ: เมือง จังหวัด: นนทบุรี รหัสไปรษณีย์: 11000 เบอร์โทร: 0809309851\n"
"นส.วราพร แซ่เติ๋น 129/1 ซ.อ่อนนุช 35 แขวงสวนหลวง เขตสวนหลวง กรุงเทพมหานคร 10250 0654201801\n"
"เนตยา ถิ่นทอง 222/234 หมู่บ้่านเออร์เบิน-สาทร ถ.ราชพฤกษ์ แขวงบางจาก ขตภาษีเจริญ กทม.. 10160 0815659384")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.