using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(?:\\\\)*'([^'\\]*(?:\\.[^'\\]*)*)'";
string input = @"[(u'apple',), (u'banana',)]
[(u'apple',), (u'banana',), (u'abc\'def',)]
\\'abc''def'
\\\'abc 'abc\\\\\'def'
|- CORRECT-|";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}